× Discussions

Turbo Fail?

  • VRX^Chiq
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 2 hours ago #18464 by VRX^Chiq
Turbo Fail? was created by VRX^Chiq
Hi All....

So my beloved 2013 ASX Aspire 1.8L Diesel started whining at me... lacking boost, and the whine is only noted under load/acceleration. At speed no sound.
It has been suggested the turbo has failed and will need replacing.

So 2 questions for my fellow ASX owners... Anyone else experienced this, and secondly, should this be covered by warranty (still have 2 months/ 15,00km left)?

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago - 3 months 3 weeks ago #18468 by Telferstr
Replied by Telferstr on topic Turbo Fail?
You should be okay re Warranty as long as you are still within the mileage limit of 60000miles.
Has the performance of the engine gone off? Sometimes there can be an air leak from the Turbo Hose which can cause the wining type noise and loss of pressure in the inlet manifold. A Hose clip/band may come loose and needs tightening up to ensure a perfect seal. Or there could be a spilt in the hose itself causing the problem.
Let us know what you find.
Regards
Telfer.
Last edit: 3 months 3 weeks ago by Telferstr.

Please Log in or Create an account to join the conversation.

  • VRX^Chiq
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 3 weeks ago - 3 months 3 weeks ago #18470 by VRX^Chiq
Replied by VRX^Chiq on topic Turbo Fail?
At Mitsubishi today to hopefully get resolved. On the way to the service centre the squeal stopped, CEL came on and had lost power, so thinking limp home mode kicked in.
Will update once officially diagnosed and resolved.
A work colleague had something similar happen to his diesel Triton a couple years ago, so might be the same thing or something different.

Edit: They said blocked hose, turbo fine, so swapped the hose and was good to go.
Got 100m out of the service centre and CEL comes on again and no boost ??‍♀️ So waiting again for issue to be solved!
Last edit: 3 months 3 weeks ago by VRX^Chiq. Reason: Update

Please Log in or Create an account to join the conversation.

  • VRX^Chiq
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 3 weeks ago #18471 by VRX^Chiq
Replied by VRX^Chiq on topic Turbo Fail?
Confirmed Turbo has packed in!
Process has started for warranty claim.
Here's hoping they won't give me headaches!

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #18473 by Telferstr
Replied by Telferstr on topic Turbo Fail?
Ah well at least they have confirmed the fault. Cant see any reason for them to reject the claim, as long as the service record is up to date and okay etc.
Please keep us posted.

Please Log in or Create an account to join the conversation.

  • VRX^Chiq
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 2 weeks ago #18477 by VRX^Chiq
Replied by VRX^Chiq on topic Turbo Fail?
No updates as yet, awaiting approval for warranty still, as my service book is at home in another state, so really they said anything even invoices for the ones not done at Mitsu.
Got no reply for invoice requests from my local mechanic, so had to have my housemate find my book and scan the pages to me (fastest option), so sent that through with the last invoice done where I am at the moment. Fingers crossed there will be no issues. Just worried cos I was about 5,000km overdue for my last service before it got done.

Please Log in or Create an account to join the conversation.

Time to create page: 5.195 seconds

Site Hosted & Managed by